Axione-IPE-Viewer/shell.nix
Félix Baylac-Jacqué 8fbad8b7b1 webapp: display interactive map + geocoding
Adding an interactive map with a geocoding search bar. We use leaflet
with the openstreetmap.fr tiles. As for the geocoding part, we use
komoot's photon API for the time being.
2022-02-21 15:28:19 +01:00

10 lines
248 B
Nix

{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = [ pkgs.libspatialite ];
nativeBuildInputs = [ pkgs.sqlite pkgs.cargo pkgs.rustc pkgs.poetry ];
shellHook = ''
LD_LIBRARY_PATH=${pkgs.libspatialite}/lib:LD_LIBRARY_PATH
'';
}